Configuración básica de switches

Posted on Actualizado enn

Esto es una lista de comandos iniciales para configurar un switch

Al final de la entrada, tienes los comandos listos para copiar y pegar en tu switch.

S1#conf terminal -> entra en el modo de configuracion

S1(config-line)#hostname S1 -> modifica el nombre del equipo a s1

S1(config)#ip domain-name cisco.com -> configura nombre de dominio

Configura contraseña de administrador y cifrado

 

S1(config)#enable password enable_pwd -> Habilita contraseña privilegios de administrador

S1(config)#enable secret secret_pwd -> Habilita contraseña privilegios de administrador contraseña encriptada

S1(config)#service password-encryption -> habilitar servicios de encriptación

S1(config)#banner motd “Acceso autorizado solo a personas con permiso” -> Mensaje informativo de acceso restringido

S1(config)#copy running-config startup-config -> Almacena configuracion

S1(config)#crypto key generate rsa -> Genera clave cifrada

S1(config)#username admin password admin_pwd -> crea usuario admin y le concede contraseña

Configura conexion a consola y conexion remota

S1(config)#ip domain-name labo.com -> Configura el dominio de trabajo

S1(config)#username cisco password 0 cisco

S1(config)#ip ssh time-out 60

S1(config)#line console 0 -> configuración passwd para acceso por consola

S1(config-line)#password console_pwd -> configuración passwd para acceso por consola

S1(config-line)#login -> configuración passwd para acceso a consola

S1(config-line)#exit – sale del modo configuracion de consola

S1(config)#line vty 0 15

S1(config-line)#transport input ssh

S1(config-line)#exit

S1(config)#ip ssh version 2

S1(config)#ip ssh time-out 30
S1(config)#ip ssh authentication-retries 3

S1(config)#crypto key generate rsa

S1(config)#username cisco privilege 15 password cisco

Deshabilita todos los puertos sin uso

S1(config)#interface range FastEthernet 0/1-24

S1(config)#shutdown

Port security

S1(config)#switchport port-security maximum 1  -> máimas conexiones permitidas para ese puerrto=1

S1(config)#switchport port-security violation shutdown ->  si se excede la política de seguridad, deshabilita el puerto

Comandos seguidos listos para ejecutar

Puedes coger los comandos, copiarlos, pegarlos y se configurará tu switch coon todas las opciones antes mencionadas.

enable

configure terminal

hostname S1

line console 0

password console_pwd

login

exit

enable password enable_pwd

enable secret secret_pwd

service password-encryption

banner motd “Acceso autorizado solo a personas con permiso”

exit

copy running-config startup-config

conf terminal
username cisco password 0 cisco
ip domain-name labo.com
ip ssh time-out 60
line vty 0 4
transport input SSH
exit
enable password cisco
crypto key generate rsa

 

exit

ip ssh version 2

interface range FastEthernet 0/1-24

shutdown

switchport port-security maximum 1

switchport port-security violation shutdown

exit

exit

copy running-config startup-config

exit

 

 

 

AUTOR: David Perez Martorell davidperezmartorell@gmail.com

Nota: Si te sirvió lo que postié, te pido 2 segundos para contestar las encuestas que figuran abajo.

Gracias!

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s