Enrutamiento entre Vlans

Posted on Actualizado enn

En este post vamos a ver lo que se llama enrutamiento entre vlans. ¿Qué es? Es asignarle un rango de ip a una vlan para que las pc que estan dentro de dicha vlan puedan comunicarse con las respectivas pc y con pcs que están en otras vlans.

SWITCH
Cambiar el modo de la interfaz(trunk)

S1(config-if)#interface [INTERNFAZ]
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk native vlan [NUMERO DE VLAN]

Cambiar el modo de la interfaz(access)

S2(config)#interface [INTERFAZ]
S2(config-if)#switchport mode access
S2(config-if)#switchport access vlan [NUMERO DE VLAN]
S2(config-if)#

Configurar la ip de default gateway en un Switch

S1(config)#ip default-gateway [IP DE ROUTER]

Asignar una IP a una Vlan

S1(config)#interface vlan [NUMERO DE VLAN]
S1(config-if)#ip address [IP] [MASCARA DE RED]

ROUTER
Configurar una subinterfaz

Router(config)#interface [INTERFAZ.UnNumero] (1)
Router(config-subif)#encapsulation dot1Q [NUMERO DE VLAN] (2)
Router(config-subif)#ip address [IP] [MASCARA DE RED]

Configurar interfaz para Vlan Nativa

Router(config-subif)#interface [INTERFAZ.UnNumero]
Router(config-subif)#encapsulation dot1Q [NUMERO DE VLAN] native
Router(config-subif)#ip address [IP] [MASCARA DE RED]

(1): Cuando ingresen dicho comando, después del punto recomiendo que pongan el numero de la vlan que van a configurar.

(2): El comando encapsulation dot1q es el protocolo que permite que el router tenga enlace troncal.

(Haciendo clic en la imagen se agranda)

 

 

AUTOR: Rodrigo

 

 

Nota: Si te sirvió lo que postié, te pido 2 segundos para contestar las encuestas que figuran abajo.

Gracias!

32 comentarios sobre “Enrutamiento entre Vlans

    Javier Pastor escribió:
    24 febrero, 2012 en 0:07

    Hola,

    Mirando el vídeo he visto que alrededor del minuto 1:04, la ventana de dialogo no esta fuera del Packet. ¿Cómo puedo conseguir que el mío haga lo mismo? Tengo la versión 5.3.0.0088

    Muchas gracias y felicidades por el blog, me ha gustado mucho.

      Admin respondido:
      24 febrero, 2012 en 0:30

      Primero que nada te agradezco por visitar mi blog. Respecto de tu duda, cual es la ventanita de dialogo que me decis? El cuadro donde escribo o la barra donde estas los equipos para seleccionar?

    Javier Pastor escribió:
    24 febrero, 2012 en 19:17

    Cuando abres S1, aparece un acceso rápido en el espacio de trabajo, en la parte inferior izquierda. He estado buscando la opción y por San google y no encuentro cómo hacerlo.

    Muchas Gracias!!

      Admin respondido:
      24 febrero, 2012 en 23:52

      Si no entiendo mal, es “boton” S1 que aparece en la parte inferioir izquierda? Si es ese nunca tuve que configurar nada, me aparece asi desde que instale el packet tracer.

    Raúl escribió:
    29 mayo, 2012 en 12:29

    Si sta todo configurado correctamente..entiendo que los paquetes que se envian desde PC1 hasta PC2, aun estando en diferentes Vlans, tienen que llegar no?

      Admin respondido:
      29 mayo, 2012 en 18:05

      Si está todo correctamente, si. Si las pc’s pertenecen a redes distintas tenes que configurar el router así pueden llegar los paquetes.

    José Luis escribió:
    10 octubre, 2012 en 2:53

    Disculpa, muy buena explicación pero, que dirección de gateway pondremos en el switch, me refiero a que hay varias subinterfaces en el router, la pregunta es ¿cual de esas direcciones es el gateway para los switches?

      Admin respondido:
      10 octubre, 2012 en 3:38

      Buenas! Lo conveniente es asignarle al switch el default gateway de la red que lo va a administrar. Podemos tener varias redes con su respectivas Vlans y lo ideal seria contar con una vlan exclusiva para administrar el switch. Espero haber respondido tu pregunta. Cualquier cosa volveme a preguntar que no hay problema.

      Saludos!

    josej escribió:
    5 noviembre, 2012 en 5:52

    Las VLANs es necesario declararlas en el Router??? Es que he hecho todo y no me sale que se comunique las computadores de diferentes VLANs

      Admin respondido:
      7 noviembre, 2012 en 18:27

      Buenas! Las vlans trabajan en capa 2(si queres comunicar 2 maquinas de la misma vlan vas a poder hacerlo sin necesidad de un router. Ahora si queres comunicar diferentes vlan si o si es necesario que estén configuradas las redes en el router.

      Saludos

    Steven escribió:
    26 noviembre, 2012 en 23:47

    Buenas mi consulta es el enlace entre el router y el sw tiene que ser trunk?

      Admin respondido:
      27 noviembre, 2012 en 0:03

      Buenas! Si tiene que estar en modo trunk.

      Saludos

    Steven escribió:
    27 noviembre, 2012 en 1:51

    Amigo gracias por la aclaración ya que la verdad estaba un tanto confuso con respecto a las vlan’s excelente tutor. Gracias también por la aclaración de la pregunta anterior…

    Jonathan escribió:
    29 noviembre, 2012 en 19:48

    buena hermano hice este ejercicio y no logro hacer ping entre los equipos. ya configure sus respectivas IP y gateway. el router no me muestra su ip. disculpa mi ignorancia. est.a muuuy bueno tu blog te felicito de verdad…

      Admin respondido:
      8 diciembre, 2012 en 17:26

      Buenas! No te preocupes si no te sale, a mi tambien me ha pasado. Fijate de tener actualizada la tabla del router(dejalo andar unos 15 segundos) y volvelo a interntar. Cualquier cosa me podes mandar la topologia.

      Saludos

    Joseph escribió:
    27 febrero, 2013 en 16:52

    Hola amigo,
    Me podrías ayudar con como configurar un multilayer??? E estado intentando y cuando hago el enrutamiento intervlan no puedo lograr la coneccion.

    Saludos!

      Admin respondido:
      1 marzo, 2013 en 22:00

      Buenas! Mándame un mail con la topología asi lo vemos en detalle.

      Saludos!

    Ernesto escribió:
    8 abril, 2013 en 7:09

    Buenas gracias por tu video esta muy bueno.
    Tengo una duda se dice que la vlan nativa no debe de usarse para propositos administrativos por seguridad, entonces como se podria configurar en tu ejemplo que la vlan99 sea nativa y sea otra vlan diferente para administrar los equipos ?

      Admin respondido:
      15 abril, 2013 en 14:19

      Buenas! Lo que podes hacer es crear otra vlan, por ejemplo Vlan 30, y asignárselas a los equipos. Entonces la vlan 99 te quedaria como nativa y no se usaria para administrar los equipos de red. Es importante que cuentes con una vlan nativa para que el trafico que no pertenece a una determinada vlan pueda llegar al destino deseado.

      Espero que te sirva,
      saludos!

    ivan escribió:
    15 abril, 2013 en 16:44

    buen dia adm:
    mira soy estudiante tengo un esenario parecido al tuyo la unica difrencia es q tu tienes del s1-ruuter un enlase yo tengo 2 ose q ocupo la int fa 0/0 y la 0/1 tengo creada 2 vlan la 10 y la 20 mi pregunta es los 2 enlases los ares tronca o asignare un enlase para cada vlan ?

      Admin respondido:
      24 abril, 2013 en 1:31

      Buenas! Te conviene hacer los 2 troncales, ya que si se cae uno el otro te sirve como auxiliar.

      Cualquier cosa volveme a preguntar,
      Saludos.

    fernando escribió:
    23 abril, 2013 en 5:26

    fernando :
    una pregunta como puedo asignar direcciones ip mediante un switch..sin usar un servidor dhcp..
    me dieron este comando..pero me marca error:
    ip dhcp pool test
    network 192.168.4.0 255.255.255.0
    default-router 192.168.4.254

      Admin respondido:
      24 abril, 2013 en 1:23

      Buenas! Lo que vos decis es correcto para un switch multi layer. Los switch comunes trabajan solo en capa 2, asi que no pueden manejar internamente el protocolo DHCP.

      Espero que te sirva,
      Saludos

    fernando escribió:
    24 abril, 2013 en 19:04

    disculpa…que te moleste…de nuevo
    me equivoque era en el router…
    como puedo configurar para que me arroje una direccion ip a cada vlan…es decir
    en mi diseño en packetracer..te explicare como esta mas o menos:

    primero tengo un router 2811 abajo de ese router —————————————————tengo un switch 2960 donde esta habilitado como puerto troncal el fastethernet 0/24 y en el router el fastethernet 0/0

    debajo de ese switch…hay otros dos switches…donde esta como troncales los puertos gigabitethernet..los tres testan enlazados con esos puertos..solo gigatethernet

    SOLAMENTE LOS DOS SWITCHES que estan debajo del switch q t mencione..cada uno tiene un HOST…es decir…tengo la vlan 2 en un switch y la vlan 3 en el otro switch…

    en el switch q esta en la parte de arriba aplique VTP( le puse un dominio y mode server y password )..cree las vlans 2 y 3

    y los switches de abajos estan como modo clientes…ya todos tienen sus pueros troncales y su puertos para cada vlan…estan son mis direcciones de red:

    v1=192.168.1.0
    v2=192.168.2.0
    v3=192.168.3.0

    ya aplique este comando tambien en este router:

    interface fasethernet 0/0
    ip address 192.168.1.254 255.255.255.0
    no shutdown

    int fa0/0.2
    ip address ip address 192.168.2.254 255.255.255.0
    encapsulation dot1Q 2

    int fa0/0.3
    ip address ip address 192.168.3.254 255.255.255.0
    encapsulation dot1Q 3

    int fa0/1
    ip address ip address 192.168.10.1 255.255.255.0
    no shutdown (en este comando..entendi es para que los dos router puedan comunicarse ya q los dos estan enlazados por el puerto fastethernet 0/1

    ————————————————————————————————————–
    en el router que te mencione esta conectado con otro router(2) estan conectados con el fastethernet 0/1…pero sigue en color rojo..y no levanta la conexion los dos routers

    en el segundo router que te mencione …abajo hay un switch…donde esta como troncal el fa0/24 y en el router el 0/0

    y debajo de ese switch esta un host donde sera la vlan 1

    v1=192.168.4.0

    para el segundo router aplique este comando.

    interface fasethernet 0/0
    ip address 192.168.4.254 255.255.255.0
    no shutdown

    int fa0/1
    ip address ip address 192.168.10.2 255.255.255.0
    no shutdown

    ———————————————————————————————————
    lo unico que quiero hacer es q las vlans se comuniquen y q estan tengan direcciones en los host. por medio de los routers..y q se levante el servicio en los dos routers..porque siguen con los puntos rojos..

    sera que me puedas ayudar…porfavor??????? q comando me hace falta

    fernando escribió:
    24 abril, 2013 en 19:04

    Admin :
    Buenas! Lo que vos decis es correcto para un switch multi layer. Los switch comunes trabajan solo en capa 2, asi que no pueden manejar internamente el protocolo DHCP.
    Espero que te sirva,
    Saludos

    fernando escribió:
    24 abril, 2013 en 19:05

    disculpa…que te moleste…de nuevo
    me equivoque era en el router…
    como puedo configurar para que me arroje una direccion ip a cada vlan…es decir
    en mi diseño en packetracer..te explicare como esta mas o menos:
    primero tengo un router 2811 abajo de ese router —————————————————tengo un switch 2960 donde esta habilitado como puerto troncal el fastethernet 0/24 y en el router el fastethernet 0/0
    debajo de ese switch…hay otros dos switches…donde esta como troncales los puertos gigabitethernet..los tres testan enlazados con esos puertos..solo gigatethernet
    SOLAMENTE LOS DOS SWITCHES que estan debajo del switch q t mencione..cada uno tiene un HOST…es decir…tengo la vlan 2 en un switch y la vlan 3 en el otro switch…
    en el switch q esta en la parte de arriba aplique VTP( le puse un dominio y mode server y password )..cree las vlans 2 y 3
    y los switches de abajos estan como modo clientes…ya todos tienen sus pueros troncales y su puertos para cada vlan…estan son mis direcciones de red:
    v1=192.168.1.0
    v2=192.168.2.0
    v3=192.168.3.0
    ya aplique este comando tambien en este router:
    interface fasethernet 0/0
    ip address 192.168.1.254 255.255.255.0
    no shutdown
    int fa0/0.2
    ip address ip address 192.168.2.254 255.255.255.0
    encapsulation dot1Q 2
    int fa0/0.3
    ip address ip address 192.168.3.254 255.255.255.0
    encapsulation dot1Q 3
    int fa0/1
    ip address ip address 192.168.10.1 255.255.255.0
    no shutdown (en este comando..entendi es para que los dos router puedan comunicarse ya q los dos estan enlazados por el puerto fastethernet 0/1
    ————————————————————————————————————–
    en el router que te mencione esta conectado con otro router(2) estan conectados con el fastethernet 0/1…pero sigue en color rojo..y no levanta la conexion los dos routers
    en el segundo router que te mencione …abajo hay un switch…donde esta como troncal el fa0/24 y en el router el 0/0
    y debajo de ese switch esta un host donde sera la vlan 1
    v1=192.168.4.0
    para el segundo router aplique este comando.
    interface fasethernet 0/0
    ip address 192.168.4.254 255.255.255.0
    no shutdown
    int fa0/1
    ip address ip address 192.168.10.2 255.255.255.0
    no shutdown
    ———————————————————————————————————
    lo unico que quiero hacer es q las vlans se comuniquen y q estan tengan direcciones en los host. por medio de los routers..y q se levante el servicio en los dos routers..porque siguen con los puntos rojos..
    sera que me puedas ayudar…porfavor??????? q comando me hace falta

      Jose escribió:
      28 noviembre, 2013 en 5:14

      Las conexions estan en verde pero no se comunican
      entre si las vlans

        Admin respondido:
        7 diciembre, 2013 en 17:33

        Buenas! Fijate de chequear que la conexion del router sea la correcta.

        Saludos

    bequer escribió:
    18 julio, 2014 en 5:25

    no me permite ingresar el comando ip default-gatewaay ..
    espero tu respuesta !

      Rodrigo respondido:
      12 diciembre, 2014 en 13:05

      Buenas! Fijate de ir poniendo una letra y apretar TAB para que te vaya tirando las opciones que acepta.

      Saludos

    Elias escribió:
    27 octubre, 2014 en 2:00

    Hey muchas gracias por tu info, es muy buena! Gracias !!!!

      Rodrigo respondido:
      12 diciembre, 2014 en 13:36

      Me alegro que te sirva!

      Saludos

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s