Configuracion de VLANs

Posted on Actualizado enn

Veamos en este post como configurar VLANS. Primero, ¿qué es una VLAN? Una VLAN es una Lan Virtual donde se puede configurar ,en un switch administrable, una cantidad de redes. El principal beneficio es que con un switch podemos tener varias redes sin necesidad de comprar varios equipos. Para mas sobre VLANS.

Creacion de VLAN

Switch#vlan database
Switch(vlan)#vlan [número de vlan] name [nombre de vlan]
Switch(vlan)#exit 

Asignamos una Vlan a un Puerto (Modo access) 

Switch(config)#interface [Interfaz]
Switch(config-if)#switchport access vlan [número de vlan]

Asignamos el modo trunk a un puerto

Switch(config)#interface [Interfaz]
Switch(config-if)#switchport mode trunk

Configuracion del Router para Vlan 

Router>en
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#no shut
Router(config-if)#interface fastEthernet 0/0.1     ---> (*)
Router(config-subif)#encapsulation dot1Q  [Número de la VLAN]
Router(config-subif)#ip address [IP] [Mascara]

Vlan database: Entrás a la base de datos para crear una nueva

Switchport: Lo que hace es cambiar para que se usa el puerto del swtich. Para que puedas acceder normalmente con una vlan lo pones en access, para que cuando lo conectes, a través de ese puerto, con otro Switch y se pasen las vlan que tienen en su base de datos (vlan database), ingresas trunk.

(*)Este .1 hace referencia a una subinterfaz del router(es virtual). Lo recomendable es que el .1 lo reemplaces por el numero de vlan, es decir, si tenes la Vlan 38 le pones 0/0.38.

(Hacer clic para agrandar la imagen)

 

AUTOR: Rodrigo

 

 

Nota: Si te sirvió lo que postié, te pido 2 segundos para contestar las encuestas que figuran abajo.

Gracias!

27 comentarios en “Configuracion de VLANs

    Raúl escribió:
    24 mayo, 2012 en 22:49

    Gracias por compartir tu sabiduría! Una cosa, se podría realizar enrutamiento estático en esta topología tal y cómo tienes expuesto en otras de tus publicaciones? Si es asi…como lo harías? GRACIAS NUEVAMENTE

      Admin respondido:
      25 mayo, 2012 en 2:43

      Gracias, me alegra que te sirva. Con respecto a tu consulta, el enrutamiento estático siempre se puede aplicar, la desventaja es el costoso mantenimiento. En la topología de este post no hace falta porque contamos con un solo router.

      Saludos!

    Pedro escribió:
    3 septiembre, 2012 en 20:39

    Muy buena practica, una duda hice todo tal cual como se muestra en la imagen pero no puedo realizar ping entre las maquinas me podrias ayudar garcias.

      Admin respondido:
      3 septiembre, 2012 en 21:08

      Buenas! Necesitaria ver la topologia con la configuracion que hiciste para ver donde está en error. Mandame un emial asi lo vemos.

      Saludos

    Yo escribió:
    1 marzo, 2013 en 11:48

    Buenisima práctica. Saludos.

    VLANs | TecnolaboratorioSTI escribió:
    8 marzo, 2013 en 18:44

    […] Video de Configuración de VLAN http://www.youtube.com/watch?v=eXvEQsuZIYk Configuracion de Vlan a traves de hyperterminal http://hera.cnice.mec.es/redes2/contenido/Pdf/mod2_redes_D.pdf Configuracion de VLAN en Packet Tracert: http://todopacketracer.wordpress.com/2011/10/18/configuracion-de-vlans/ […]

    Alberto escribió:
    10 mayo, 2013 en 17:15

    Hola, es muy buena la información.
    Pero como se cambian los puertos hacia otra VLAN, es decir por ejemplo.

    interface range fastethernet0/2-8
    switchport mode access
    switchport access vlan 2
    no shutdown
    exit

    y ahora quiero que la fa 0/8 pertenezca a la VLAN 3, ¿Cómo le hago?

      Admin respondido:
      10 mayo, 2013 en 17:35

      Buenas! Primero que rango lo pondria de 2 a 7 y en la interfaz 8 haria lo siguiente.

      interface fastethernet0/8
      switchport mode access
      switchport access vlan 3
      no shutdown
      exit

      Saludos

    miguel escribió:
    22 mayo, 2013 en 0:52

    Hola buenas no se nada de configuracion de swich Vlan en donde estoy trabajando estamos pensando usar swich manager por la seguridad, pero quiero saber si con un Swich manager ya se puede tener todo el control y seguridad o es posible seguir usando lo swich normales o se debe de cambiar O colocar todos los swich normales a swich manager tan bien para poder tener mayor seguridad en el net.

      Admin respondido:
      22 mayo, 2013 en 1:04

      Buenas! Habría que ver bien la topologia y los servicios que corren en la red para poder hacer una evaluación mas precisa y concreta sobre que políticas o acciones a tomar son las mejores. En principio te diría que si tienen que comprar el equipo vean la posibilidad de analizar con profundidad que es lo que hay que proteger, definir prioridades, y si se puede hacer algo con lo que ya tienen.

      Espero que te sirva,
      Saludos

    Sergio escribió:
    9 septiembre, 2013 en 17:34

    Muchas gracias, estaba haciendo un ejercicio similar y gracias a tu aporte supe dónde estaba el error

      Admin respondido:
      11 septiembre, 2013 en 13:57

      Buenas! Me alegro que te haya servido!!

      Saludos

        José escribió:
        28 octubre, 2013 en 21:18

        Hola, soy nuevo es esto de simulación de redes, estoy aprendiendo y me han sido de gran utilidad tu material, salvo en esta practica de vlan, me confundí, el punto es que me dejaron configurar vlan para 4 subredes, a partir de una ip (192.0.0.0) ya hice el subneteo y todo lo básico, configure y hasta ahí no tengo problema, el detalle que se necesita que se conecte a un router para que permita el envio de paquetes entre diferentes segmentos de vlan, intente seguir la explicación ta como la pusiste pero no me funciona :S, podrias explicarme por favor? Nos pidieron 5 pc para las primeras 3 vlan y 9 para la cuarta, y utilizar solo 1 router. Espero puedas explicarme…

        Admin respondido:
        29 octubre, 2013 en 0:21

        Buenas! Me mandas al mail la topología así lo veo y te ayudo.

        Saludos

    tito escribió:
    25 septiembre, 2013 en 18:04

    muy buena practica

    Agustin escribió:
    8 octubre, 2013 en 20:37

    Desearía saber si a cualquier puerto le puedo asignar un Tunk, ya que lei que se debe asignar a los puertos 26 o 27, si un switch solo tiene 24 puertos o se aplica a los que tienen 48 puetos ?????? Gracias por sacarme de la duda. By

      Admin respondido:
      29 octubre, 2013 en 0:18

      Buenas! Podes cambiarle el modo a cualquier puerto del switch. No hace falta que sea el 25,26. Lo que tenes q tener en claro es que conviene cambiarle el modo al puerto que va a conectarse con otro equipo(sw o router) en caso de ser necesario.

      Espero que te sirva!
      Saludos

    carolina escribió:
    16 enero, 2014 en 4:57

    hola como estas disculpa pero en esta configuracion del switch 1 no vi que hayas configurado la fa 0/1 como modo trunkal. no es necesario o te la comiste ?

      Admin respondido:
      4 febrero, 2014 en 13:18

      Buenas! Puede ser que me lo haya olvidado de configurar pero si, es necesario que ese enlace sea trunkeado.

      Saludos!

    Junior Grados escribió:
    6 febrero, 2014 en 20:03

    Hola ante todo gracias por haber compartido tus conocimientos, con respecto a lo visto, entiendo la configuración del sw pero quisiera saber por qué el enlace con el Router esta en modo troncal, es recomendable ponerlo en ese modo? Gracias.

      Admin respondido:
      23 febrero, 2014 en 23:35

      Buenas! En enlace con el router esta asi para que se puedan transportar todas las vlans. En el post enrutamiento entre vlans vas a ver que al router le llegan varias vlans, las cuales son redes diferentes.

      Espero que te sirva
      Saludos

    Luis Rodriguez escribió:
    28 marzo, 2014 en 16:02

    Hola, tengo un duda. Al realizar la practica he encontrado un error que no sé resolver. Resulta que si a los PC’s se le pone la Gateway por defecto asignada a las entradas virtuales del router ( f1/0.x) . El router hace su función de comunicar dos redes diferentes y pueden conseguir hacer pin entre dos Vlan distintas. Cuando esto pasa, no tiene sentido realizar las VLAN’s porque no aisla nada. Se puede resolver?. Muchas gracias.

      Admin respondido:
      1 abril, 2014 en 15:33

      Buenas! Lo conveniente es encapsular eso con VLANS. Por que? Porque al crear una topología con vlans tenes informacion sobre a que red y con su nombre pertenece cada PC. ES mucho más administrable que tener ips virtuales sin implementar vlans. Aparte podes definir ciertas reglas de forma mas organizada.

      Saludos

    Santiago escribió:
    30 marzo, 2014 en 18:42

    no entiendo en esta parte: “Router(config-subif)#ip address [IP] [Mascara]” se pone la ip address de que?

      Admin respondido:
      1 abril, 2014 en 15:23

      Buenas! Se le pone la ip que elegís como default gateway o puerta de enlace predeterminada de dicha red. Es como si cada subinterfaz fuese una red física distinta.
      Espero que te sirva!
      Saludos

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s